Функция ВПР (VLOOKUP)

Функция ВПР является одной из наиболее часто используемых при работе с данными в Excel. Функция не лишена недостатков, но ее обязательно следует освоить для понимая механизма работы с данными в Excel.

Описание функции ВПР

С помощью функции ВПР можно выполнить поиск в первом столбце диапазона ячеек и получить значение из любой ячейки в той же строке диапазона. Предположим, что в диапазоне A2:C10 содержится список сотрудников. Идентификаторы сотрудников хранятся в первом столбце диапазона, как показано на рисунке.

Таблица с данными для выборки с помощью ВПР

Если известен идентификатор сотрудника, с помощью функции ВПР можно вернуть отдел, в котором он работает, или его имя. Чтобы получить имя сотрудника под номером 38, можно использовать формулу:

=ВПР(38; A2:C10; 3; ЛОЖЬ)
Эта формула находит значение 38 в первом столбце диапазона A2:C10, а затем возвращает значение, содержащееся в третьем столбце той же строки, что и у искомого значения (“Алексей Орехов”).

Буква “В” в названии функции ВПР означает “вертикально”. Функция ВПР используется вместо функции ГПР, если сравниваемые значения расположены в столбце слева от искомых данных.

Синтаксис

=ВПР(искомое_значение; таблица; номер_столбца; [интервальный_просмотр])

Аргументы

искомое_значениетаблицаномер_столбцаинтервальный_просмотр
Обязательный. Значение, которое должно быть найдено в первом столбце таблицы или диапазона. Аргумент искомое_значение может быть значением или ссылкой. Если искомое_значение меньше, чем наименьшее значение в первом столбце аргумента таблица, функция ВПР возвращает значение ошибки #Н/Д.
Обязательный. Диапазон ячеек, содержащий данные. Можно использовать ссылку на диапазон (например, A2:D8) или имя диапазона. Значения в первом столбце аргумента таблица — это значения, в которых выполняется поиск аргумента искомое_значение. Эти значения могут быть текстовыми, числовыми или логическими. Текстовые значения в нижнем и верхнем регистре считаются эквивалентными.
Обязательный. Номер столбца в аргументе таблица, из которого возвращается совпадающее значение. Если номер_столбца равен 1, то возвращается значение из первого столбца аргумента таблица; если номер_столбца равен 2, — значение из второго столбца аргумента таблица и т. д.

Если значение аргумента номер_столбца:

  • меньше 1, функция ВПР возвращает значение ошибки #ЗНАЧ!;
  • больше, чем число столбцов в аргументе таблица, функция ВПР возвращает значение ошибки #ССЫЛ!.

Необязательный. Логическое значение, определяющее, какое совпадение должна найти функция ВПР — точное или приблизительное.

Если аргумент интервальный_просмотр имеет значение ИСТИНА или опущен, то возвращается точное или приблизительное совпадение. Если точное совпадение не найдено, то возвращается наибольшее значение, которое меньше, чем искомое_значение.

Внимание! Если аргумент интервальный_просмотр имеет значение ИСТИНА или опущен, значения в первом столбце аргумента таблица должны быть расположены в возрастающем порядке, иначе функция ВПР может вернуть неправильный результат.

Если аргумент интервальный_просмотр имеет значение ЛОЖЬ, функция ВПР ищет только точное совпадение. Если в первом столбце аргумента таблица имеется несколько значений, соответствующих аргументу искомое_значение, используется первое найденное значение. Если точное совпадение не найдено, возвращается значение ошибки #Н/Д.

Замечания

  • При поиске текстовых значений в первом столбце аргумента таблица убедитесь, что данные в этом столбце таблицы не содержат начальных пробелов, конечных пробелов, используемых не по правилам прямых ( ‘ или ” ) и “парных” ( ‘ или “ ) кавычек или непечатаемых символов. В этих случаях функция ВПР может вернуть неправильное или непредвиденное значение.
  • При поиске числовых значений или значений дат убедитесь, что данные в первом столбце аргумента таблица не являются текстовыми значениями. В этом случае функция ВПР может вернуть неправильное или непредвиденное значение.
  • Если значение аргумента “интервальный_просмотр”ЛОЖЬ, а аргумент искомое_значение представляет собой текст, то в аргументе искомое_значение допускается использование подстановочных знаков: вопросительного знака (?) и звездочки (*). Вопросительный знак соответствует любому одиночному символу; звездочка — любой последовательности символов. Если нужно найти сам вопросительный знак или звездочку, поставьте перед ними знак тильды (~).

Пример

Видео работы функции

Разбор ВПРСравнение двух файловРешение задач #ExcelWorldChamp

Дополнительные материалы

Как сравнить два файла MS Excel
#Excelwordlchamp 1-1 Решаем задачи первого тура

Scroll Up