Функция ЕСЛИ (IF)

Функция ЕСЛИ является наиболее популярной среди логических функций Excel, она возвращает одно значение, если указанное условие дает в результате значение ИСТИНА, и другое значение, если условие дает в результате значение ЛОЖЬ.

Описание функции ЕСЛИ

Функция ЕСЛИ возвращает одно значение, если указанное условие дает в результате значение ИСТИНА, и другое значение, если условие дает в результате значение ЛОЖЬ. Например, формула

=ЕСЛИ(A1>10,"Больше 10","10 или меньше") 

возвращает строку “Больше 10”, если значение в ячейке A1 больше 10, и “10 или меньше”, если оно меньше или равно 10.

Синтаксис

=ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь])

Аргументы

лог_выражениезначение_если_истиназначение_если_ложь
Обязательный аргумент. Любое значение или выражение, дающее в результате значение ИСТИНА или ЛОЖЬ. Например, A10=100 — логическое выражение; если значение в ячейке A10 равно 100, это выражение принимает значение ИСТИНА, в противном случае — значение ЛОЖЬ. В этом аргументе может использоваться любой оператор сравнения.
Необязательный аргумент. Значение, которое возвращается, если аргумент лог_выражение соответствует значению ИСТИНА. Например, если данный аргумент — строка “В пределах бюджета”, а аргумент лог_выражение соответствует значению ИСТИНА, функция ЕСЛИ возвращает текст “В пределах бюджета”. Если аргумент лог_выражение соответствует значению ИСТИНА, а аргумент значение_если_истина опущен (т. е. после аргумента лог_выражение есть только запятая), возвращается значение 0. Чтобы отобразить слово ИСТИНА, используйте логическое значение ИСТИНА в качестве этого аргумента.
Необязательный аргумент. Значение, которое возвращается, если аргумент лог_выражение соответствует значению ЛОЖЬ. Например, если данный аргумент — строка “Превышение бюджета”, а аргумент лог_выражение соответствует значению ЛОЖЬ, функция ЕСЛИ возвращает текст “Превышение бюджета”. Если аргумент лог_выражение соответствует значению ЛОЖЬ, а аргумент значение_если_ложь опущен (т. е. после аргумента значение_если_истина нет запятой), функция ЕСЛИ возвращает логическое значение ЛОЖЬ. Если аргумент лог_выражение соответствует значению ЛОЖЬ, а значение аргумента значение_если_ложь пусто (т. е. после аргумента значение_если_истина стоит только запятая), функция ЕСЛИ возвращает значение 0 (ноль).

Замечания

  • Для создания более сложных проверок в качестве аргументов значение_если_истина и значение_если_ложь можно использовать до 64 вложенных функций ЕСЛИ (использование вложенных функций ЕСЛИ см. в примере 3). Кроме того, для проверки нескольких условий можно использовать функции ПРОСМОТР, ВПР, ГПР и ВЫБОР (использование функции ПРОСМОТР см. в примере 4).
  • Если какой-либо из аргументов функции ЕСЛИ является массивом, при выполнении функции ЕСЛИ вычисляются все элементы массива.
  • Приложение Excel предоставляет дополнительные функции, которые можно применять для анализа данных с использованием условий. Например, для подсчета числа вхождений текстовой строки или числа в диапазон ячеек используйте функции листа СЧЁТЕСЛИ и СЧЁТЕСЛИМН. Для вычисления суммы значений, попадающих в диапазон, заданный текстовой строкой или числами, используйте функции СУММЕСЛИ и СУММЕСЛИМН.

Пример

Видео работы функции

Сравнение двух файлов Excel

Дополнительные материалы

Как сравнить два файла MS Excel

Scroll Up