Функция ТЕКСТ (TEXT)

Функция ТЕКСТ преобразует численное значение в текст и позволяет задать формат отображения с помощью специальных строк форматирования.

Описание функции ТЕКСТ

Функция ТЕКСТ преобразует численное значение в текст и позволяет задать формат отображения с помощью специальных строк форматирования. Эта функция полезна, если числа требуется отобразить в более удобном формате или если требуется объединить числа с текстом или символами.

Например, чтобы отформатировать число 23,5 как сумму в рублях, можно использовать указанную ниже формулу:

=ТЕКСТ(A1,"0,00р.")

Результат: 23,50р.

Числа также можно форматировать с помощью команд в группе Число, которая находится на вкладке ленты Главная. Однако эти команды работают лишь в том случае, если ячейка содержит только число. Если требуется отформатировать число и объединить его с другим текстом, лучше всего использовать функцию ТЕКСТ. Например, к предыдущей формуле можно добавить следующий текст:

=ТЕКСТ(A1,"0,00р.")& " в час"

Результат: 23,50р. в час.

Синтаксис

=ТЕКСТ(значение; формат)

Аргументы

значениеформат
Обязательный аргумент. Численное значение, формула, вычисление которой дает числовое значение, или ссылка на ячейку, содержащую численное значение.
Обязательный аргумент. Численный формат в виде текстовой строки в кавычках (например, “Д.М.ГГГГ” или “# ##0,00”. Правила форматирования представлены ниже.

Форматы чисел

Заполнитель Описание
0 (ноль) Отображает незначащие нули, если число имеет меньше разрядов, чем количество нулей в строке форматирования. Например, формат #,00 позволяет отобразить значение 8,9 как 8,90.
# Работает так же, как 0 (ноль). Но в этом случае функция Text не возвращает дополнительные нули, если число имеет слева или справа от десятичного разделителя меньше цифр, чем количество символов # в строке форматирования. Например, число 8,9 при использовании формата #,## будет отображаться как 8,9.
? Действует по тем же правилам, что и 0 (нуль). Однако, до и после запятой вместо незначащих нулей отображаются пробелы, чтобы десятичные разделители были выровнены в столбце. Например, формат 0,0? обеспечивает выравнивание запятых для чисел 8,9 и 88,99. (Правда, для чистоты эксперимента, следует выбрать моноширинный шрифт)
, (запятая) Отображает символ десятичного разделителя. Поведение этого символа зависит от языка пользовательского формата.

Если в дробной части числа больше цифр, чем заполнителей в формате, число округляется до количества разрядов, равного количеству заполнителей. Если в целой части числа больше цифр, чем заполнителей в формате, отображаются дополнительные цифры. Если формат содержит слева от запятой только знаки номера ( #), то числа, меньшие 1, будут начинаться с запятой, например ,47.

Для отображения В виде Используемый формат
1234,59 1234,6 “####,#”
8,9 8,900  “#,000”
0,631  0,6  “0,#”
12
1234,568
12,0
1234,57
“#,0#”
44,398
102,65
2,8
44,398
102,65
2,8
(с выравниванием запятых)
“???,???”
5,25
5,3
5 1/4
5 3/10
(с выравниванием дробных частей)
“# ???/???”

Разделитель групп разрядов

Чтобы отображать пробел в качестве разделителя групп разрядов или представлять число в масштабе, кратном 1000, включите в числовой формат разделитель, указанный ниже.

Для отображения В виде Используемый формат
12000 12 000 “# ###”
12000 12 “# “
12200000 12,2 “0,0 “

Форматы даты и времени. Дни, месяцы и годы.    Для отображения чисел в формате даты (с указанием числа, месяца и года) в аргументе формат используются коды, указанные ниже.

Формат Описание
М Отображение месяца в виде числа без начального нуля.
ММ Отображение месяца в виде числа с начальным нулем, если он необходим.
МММ Отображение сокращенного названия месяца (Янв–Дек).
ММММ Отображение полного названия месяца (Январь–Декабрь).
МММММ Отображение месяца в виде одной буквы (Я–Д).
Д Отображение дня в виде числа без начального нуля.
ДД Отображение дня в виде числа с начальным нулем, если он необходим.
ДДД Отображение сокращенного названия дня недели (пн–вс).
ДДДД Отображение полного названия дня недели (понедельник–воскресенье).
ГГ Отображение года в виде двузначного числа.
ГГГГ Отображение года в виде четырехзначного числа.
Для отображения В виде Используется форма
Месяцев 1-12 “М”
Месяцев 01-12 “ММ”
Месяцев Янв-Дек “МММ”
Месяцев Январь-Декабрь “ММММ”
Месяцев Я-Д “МММММ”
Дней 1-31 “Д”
Дней 01-31 “ДД”
Дней пн-вс “ДДД”
Дней понедельник-воскресенье “ДДДД”
Лет 00-99 “ГГ”
Лет 1900-9999 “ГГГГ”

Часы, минуты и секунды

Для отображения чисел в формате времени (с указанием часов, минут и секунд) в аргументе формат используются коды, указанные ниже.

Формат Описание
ч Отображение часов в виде числа без начального нуля.
[ч] Отображение истекшего времени в часах. Если формула возвращает значение времени, в котором число часов превышает 24, используйте числовой формат наподобие следующего: [ч]:мм:сс.
чч Отображение часов в виде числа с начальным нулем, если он необходим. Если формат содержит пометку AM или PM, часы отображаются на основе 12-часового цикла. В противном случае используется 24-часовой цикл.
м Отображение минут в виде числа без начального нуля.

Примечание. Код м или мм должен быть указан непосредственно после кода ч или чч или непосредственно перед кодом сс, иначе вместо минут отображается месяц.

[м] Отображение истекшего времени в минутах. Если формула возвращает значение времени, в котором число минут превышает 60, используйте числовой формат наподобие следующего: [мм]:сс.
мм Отображение минут в виде числа с начальным нулем, если он необходим.

Примечание.   Код м или мм должен быть указан непосредственно после кода ч или чч или непосредственно перед кодом сс, иначе вместо минут отображается месяц.

с Отображение секунд в виде числа без начального нуля.
[с] Отображение истекшего времени в секундах. Если формула возвращает значение времени, в котором число секунд превышает 60, используйте числовой формат наподобие следующего: [сс].
сс Отображение секунд в виде числа с начальным нулем, если он необходим. Для отображения долей секунды используйте числовой формат наподобие следующего: ч:мм:сс,00.
AM/PM, am/pm, A/P, a/p Отображение часов на основе 12-часового цикла. Коды AM, am, A и a означают время суток от полуночи до полудня, а PM, pm, P и p — время от полудня до полуночи.
Для отображения В виде Используется форма
Часов 0-23 “ч”
Часов 00-23 “чч”
Минут 0-59 “м”
Минут 00-59 “мм”
Секунд 0-59 “с”
Секунд 00-59 “сс”
Времени 4:00 “ч:мм”
Времени 16:04 “чч:мм”
Времени 3:32:05 “ч:мм:сс”
Времени 3:32:05,75 “ч:мм:сс,00”
Времени 1:02 “[ч]:мм”
Истекшего времени (в часах и минутах) 63:23 “[мм]:сс”
Истекшего времени (в часах и минутах) 3456,70 “[сс],00”

Форматы денежных сумм, процентов и экспоненциального представления

Символы валют. Чтобы указать перед числом знак доллара ($), введите его в начале аргумента формат (например, “$# ##0,00”). Чтобы включить в числовой формат один из указанных ниже символов валют, нажмите клавишу NUM LOCK и введите с цифровой клавиатуры код ANSI соответствующего символа.

Символ Сочетание клавиш
¢  ALT+0162
£  ALT+0163
¥  ALT+0165
Евро ALT+0128
  • Примечание.   Необходимо использовать цифровую панель клавиатуры. При использовании клавиши ALT с цифрами верхнего ряда клавиш коды ANSI не генерируются.
  • Процентные значения.    Чтобы отображать числа в виде процентов — например, 0,08 как 8% или 2,8 как 280%, — включите в аргумент формат знак процента (%).
  • Экспоненциальное представление.    Для отображения чисел в экспоненциальном формате включите в аргумент формат код из числа указанных ниже.
Формат Описание
E (E-, E+, e-, e+) Задает отображение числа в экспоненциальном представлении. В Microsoft Excel отображается знак экспоненты (“E” или “e”) и справа от него число, показывающее, на сколько разрядов перенесена запятая. Например, если аргумент формат содержит значение “0,00E+00”, то число 12200000, отображается как 1,22E+07. Если аргумент формат изменить на “#0,0E+0”, будет отображено число 12,2E+6.

Включение текста и добавление пробелов

Если в аргумент формат включить любой из указанных ниже символов, они будут отображаться так же, как были введены.

Символ Пояснение
$ Знак доллара
+ Знак “плюс”
( Левая круглая скобка
: Двоеточие
^ Диакритический знак (крышка)
Апостроф
{ Левая фигурная скобка
< Знак “меньше”
= Знак равенства
Знак “минус”
/ Косая черта
) Правая круглая скобка
! Восклицательный знак
& Амперсанд
~ Тильда
} Правая фигурная скобка
> Знак “больше”
Пробел

Замечания

  • Аргумент формат не может содержать звездочку (*).
  • Функция ТЕКСТ преобразует число в форматированный текст, и результат больше не может быть использован в вычислениях в качестве числа. Чтобы отформатировать число и при этом оставить его числом, щелкните ячейку правой кнопкой мыши, выберите команду Формат ячеек и в диалоговом окне Формат ячеек на вкладке Число настройте нужные параметры форматирования. Для получения дополнительных сведений об использовании диалогового окна Формат ячеек нажмите кнопку справки (?) в верхнем правом углу окна.

Пример

Дополнительные материалы

Файл Excel с примерами использования функции ТЕКСТ (на английском языке)

Scroll Up