Функция ИНДЕКС (INDEX)

Функция ИНДЕКС возвращает значение или ссылку на значение из таблицы или диапазона. Вместе с функцией ПОИСКПОЗ функция ИНДЕКС являет собой более гибкую и мощною альтернативу функции ВПР

Описание функции ИНДЕКС

Функция ИНДЕКС возвращает значение или ссылку на значение из таблицы или диапазона, она имеет две формы: ссылочную и форму массива.
 
Форма массиваСсылочная форма

Форма массива

Возвращает значение элемента таблицы или массива, заданного номером строки и номером столбца. Если первый аргумент функции ИНДЕКС является константной массива, используйте форму массива.

Синтаксис

=ИНДЕКС(массив, номер_строки, [номер_столбца])

Аргументы

массив
номер_строки
номер_столбца

Замечания

  • Если используются оба аргумента — и “номер_строки”, и “номер_столбца”, — функция ИНДЕКС возвращает значение ячейки на пересечении указанных строки и столбца.
  • Если указать в качестве аргумента “номер_строки” или “номер_столбца” значение 0 (ноль), функция ИНДЕКС возвратит массив значений для целого столбца или целой строки соответственно. Чтобы использовать значения, возвращенные как массив, введите функцию ИНДЕКС как формулу массива в горизонтальный диапазон ячеек для строки и в вертикальный — для столбца. Чтобы ввести формулу массива, нажмите сочетание клавиш CTRL+SHIFT+ENTER.
  • В Excel Web App невозможно создавать формулы массива.
  • Аргументы “номер_строки” и “номер_столбца” должны указывать на ячейку внутри заданного массива; в противном случае функция ИНДЕКС возвратит значение ошибки #ССЫЛКА!.

Пример

Ссылочная форма

Возвращает ссылку на ячейку, расположенную на пересечении указанной строки и указанного столбца. Если ссылка составлена из не смежных выделенных диапазонов, можно указать, какой из них требуется использовать.

Синтаксис

=ИНДЕКС(ссылка; номер_строки; [номер_столбца]; [номер_области])

Аргументы

ссылка
номер_строки
номер_столбца
номер_области

Замечания

  • После того как с помощью аргументов “ссылка” и “номер_области” выбран диапазон, с помощью аргументов “номер_строки” и “номер_столбца” выбирается конкретная ячейка: номер строки 1 соответствует первой строке диапазона, номер столбца 1 — его первому столбцу и т. д. Ссылка, возвращаемая функцией ИНДЕКС, указывает на пересечение строки “номер_строки” и столбца “номер_столбца”.
  • Если указать в качестве аргумента “номер_строки” или “номер_столбца” значение 0 (ноль), функция ИНДЕКС возвратит ссылку на целый столбец или целую строку соответственно.
  • Аргументы “номер_строки”, “номер_столбца” и “номер_области” должны указывать на ячейку внутри аргумента “ссылка”; в противном случае функция ИНДЕКС возвращает значение ошибки #ССЫЛКА!. Если аргументы “номер_строки” и “номер_столбца” опущены, функция ИНДЕКС возвращает область в аргументе “ссылка”, заданную аргументом “номер_области”.
  • Результатом вычисления функции ИНДЕКС является ссылка, которая интерпретируется в качестве таковой другими функциями. В зависимости от формулы значение, возвращаемое функцией ИНДЕКС, может использоваться как ссылка или как значение. Например, формула ЯЧЕЙКА(“ширина”;ИНДЕКС(A1:B2;1;2)) эквивалентна формуле ЯЧЕЙКА(“ширина”;B1). Функция ЯЧЕЙКА использует значение, возвращаемое функцией ИНДЕКС, как ссылку. С другой стороны, такая формула, как 2*ИНДЕКС(A1:B2;1;2), преобразует значение, возвращаемое функцией ИНДЕКС, в число в ячейке B1.

Пример

Видео работы функции

Альтернатива ВПР#ExcelWordlChamp 1-2#ExcelWordlChamp 3-4

Дополнительные материалы

Альтернатива функции ВПР (VLOOKUP)
#ExcelWordlChamp 1-2 решаем задачи первого тура часть 2
#ExcelWorldChamp 3-4 последнее взрывоопасное задание

Scroll Up