Функция СЧЁТЕСЛИ (COUNTIF)

Функция СЧЁТЕСЛИ подсчитывает количество ячеек в диапазоне, которые соответствуют одному указанному пользователем критерию.

Описание функции СЧЁТЕСЛИ

Подсчитывает количество ячеек в диапазоне, которые соответствуют одному указанному пользователем критерию. Например, можно подсчитать количество всех ячеек, которые начинаются с определенной буквы или содержат числа, большие или меньшие указанного значения.

Предположим, что есть лист со списком задач в столбце «A», а имя пользователя, ответственного за каждую из задач, указано в столбце «B». Для подсчета количества повторений имени ответственного в столбце «B» можно использовать функцию СЧЁТЕСЛИ. Это позволяет определить количество задач, назначенных этому пользователю.

Пример:

=СЧЁТЕСЛИ(B2:B25;"Валентин")

Если нужно подсчитать значения на основании нескольких критериев, следует воспользоваться функцией СЧЁТЕСЛИМН.

Синтаксис

=СЧЁТЕСЛИ(диапазон; критерий)

Аргументы

диапазонкритерий
Обязательный аргумент. Одна или несколько ячеек, по которым требуется выполнить подсчет. В этих ячейках могут находиться числа, имена, массивы или ссылки на числа. Пустые ячейки и текстовые значения пропускаются.
Обязательный аргумент. Число, выражение, ссылка на ячейку или текстовая строка, которая определяет, какие ячейки нужно подсчитать. Например, критерий может быть выражен как 32, «>32», В4, «яблоки» или «32».

  • В этом аргументе можно использовать подстановочные знаки: вопросительный знак (?) и звездочку (*). Вопросительный знак соответствует любому символу, звездочка — любой последовательности символов. Для поиска самого вопросительного знака или звездочки следует ввести перед ними тильду (~).
  • Условие не чувствительно к регистру. Например, строкам «яблоки» и «ЯБЛОКИ» будут соответствовать одни и те же ячейки.

Замечания

  • Функция СЧЁТЕСЛИ возвращает неправильные результаты, если она используется для сопоставления строк длиннее 255 символов со строкой #ЗНАЧ!.

Пример

Видео работы функции

Подсчёт уникальных значений#ExcelWorldChamp 2-4

Дополнительные материалы

Простая формула подсчета уникальных записей диапазона
#ExcelWorldChamp 2-4 упражнения с формулами. Хитрые судьи.

Scroll Up