ВЫБОР (CHOOSE)

Функция ВЫБОР (CHOOSE)

Использует номер_индекса, чтобы выбрать и вернуть значение из списка аргументов-значений. Функция ВЫБОР позволяет выбрать одно значение из списка, в котором может быть до 254 значений. Например, если первые семь значений — это дни недели, то функция ВЫБОР возвращает один из дней при использовании числа от 1 до 7 в качестве аргумента "номер_индекса".

Синтаксис

ВЫБОР(номер_индекса;значение1;[значение2];...)

Аргументы:

  • Номер_индекса    — обязательный аргумент. Номер выбираемого аргумента-значения. Номер индекса должен быть числом от 1 до 254, формулой или ссылкой на ячейку, содержащую число в диапазоне от 1 до 254. 
    • Если номер_индекса равен 1, то функция ВЫБОР возвращает значение1; если он равен 2, возвращается значение2 и так далее.
    • Если номер_индекса меньше 1 или больше, чем номер последнего значения в списке, то функция ВЫБОР возвращает значение ошибки #ЗНАЧ!.
    • Если номер_индекса представляет собой дробь, то он усекается до меньшего целого.
  • Значение1, значение2, ...     — аргумент "значение1" является обязательным, следующие за ним — нет. От 1 до 254 аргументов-значений, из которых функция ВЫБОР, используя номер индекса, выбирает значение или выполняемое действие. Аргументы могут быть числами, ссылками на ячейки, определенными именами, формулами, функциями или текстом.

Замечения:

  • Если номер_индекса является массивом, то при выполнении функции ВЫБОР вычисляется каждое значение.
  • Аргументы-значения функции ВЫБОР могут быть как ссылками на интервал, так и отдельными значениями.

​Например, формула:

=СУММ(ВЫБОР(2;A1:A10;B1:B10;C1:C10))

равна формуле:

=СУММ(B1:B10)

которая возвращает значение, вычисленное на основе значений в интервале ячеек B1:B10.

В этом примере сначала вычисляется функция ВЫБОР, которая возвращает ссылку на интервал B1:B10. Затем вычисляется функция СУММ, причем в качестве аргумента используется интервал B1:B10, то есть результат функции ВЫБОР.

Пример:


Scroll Up