СЧЁТЕСЛИ (COUNTIF)

Функция СЧЁТЕСЛИ (COUNTIF)

Функция СЧЁТЕСЛИ подсчитывает количество ячеек в диапазоне, которые соответствуют одному указанному пользователем критерию. Например, можно подсчитать количество всех ячеек, которые начинаются с определенной буквы или содержат числа, большие или меньшие указанного значения. Предположим, например, что есть лист со списком задач в столбце A, а имя пользователя, ответственного за каждую из задач, указано в столбце B. Для подсчета количества повторений имени ответственного в столбце B можно использовать функцию СЧЁТЕСЛИ. Это позволяет определить количество задач, назначенных этому пользователю. Пример:

=СЧЁТЕСЛИ(B2:B25;"Валентин")

Синтаксис

СЧЁТЕСЛИ(диапазон;критерий)

Примечание. Если необходимо подсчитать количество ячеек на основании нескольких критериев, используйте функцию СЧЁТЕСЛИМН.

Аргументы:

  • Диапазон.    Обязательный аргумент. Одна или несколько ячеек, по которым требуется выполнить подсчет. В этих ячейках могут находиться числа, имена, массивы или ссылки на числа. Пустые ячейки и текстовые значения пропускаются.
  • Условие.    Обязательный аргумент. Число, выражение, ссылка на ячейку или текстовая строка, которая определяет, какие ячейки нужно подсчитать. Например, критерий может быть выражен как 32, ">32", В4, "яблоки" или "32".

Примечания

  • В этом аргументе можно использовать подстановочные знаки: вопросительный знак (?) и звездочку (*). Вопросительный знак соответствует любому символу, звездочка — любой последовательности символов. Для поиска самого вопросительного знака или звездочки следует ввести перед ними тильду (~).
  • Условие не чувствительно к регистру. Например, строкам "яблоки" и "ЯБЛОКИ" будут соответствовать одни и те же ячейки.

​Замечания

  • Функция СЧЁТЕСЛИ возвращает неправильные результаты, если она используется для сопоставления строк длиннее 255 символов со строкой #ЗНАЧ!.

Пример:

Материалы с данной функцией:

Простая формула подсчета уникальных записей диапазона


Scroll Up