Домой Статьи Excel Подсчет уникальных записей диапазона в Excel

Подсчет уникальных записей диапазона в Excel

Иногда, имя определенный набор данных, например, перечень имен, фруктов, или числовые записи, возникает необходимость посчитать не общее количество записей, а только количество уникальных записей.

Смотрите также видеоверсию статьи «Подсчет уникальных записей диапазона в Excel».

Если необходимо подсчитать общее количество числовых данных, то используется функция СЧЁТ (COUNT), а если необходимо посчитать не числовые данные, тогда – СЧЁТЗ (COUNTA).

Для подсчета уникальных записей используется следующая конструкция из формул СУММ (SUM) и СЧЁТЕСЛИ (COUNTIF):

=СУММ(1/СЧЁТЕСЛИ(A2:A11;A2:A11))

это формула массива, т.е. после ее введения необходимо нажимать не просто «Enter», а сочетание «Ctrl+Shift+Enter».

Если в перечне нет пустых ячеек конструкция отлично работает, но, если попадется пустая ячейка, формула выдаст ошибку. Чтобы иметь возможность считать уникальные записи в массивах с пустыми ячейками, необходима небольшая модернизация формулы добавлением функции ЕСЛИОШИБКА (IFERROR):

=СУММ(ЕСЛИОШИБКА(1/СЧЁТЕСЛИ(A2:A13;A2:A13);0))

Встречаем новый Excel, Microsoft представила динамические массивы (Dynamic Array Functions)

24 сентября 2018 года Microsoft представила одно из самых существенных изменений в Excel за последнее десятилетие - Dynamic Array...

Горизонтальная сортировка в Excel

В большинстве случаев работы с данными они организованны вертикально, поэтому когда подразумевается обработка имеется ввиду именно вертикальная обработка данных,...

Автонумерация внутри составной записи в Excel

Автозаполнение в в Excel относится к базовому функционалу ввода различных типов данных, который следует изучить в первую очередь. Благо...

Еще записей в тему?
Если честно, некоторые могут быть не свежие:)