Подсчет уникальных записей диапазона в Excel

Иногда, имя определенный набор данных, например, перечень имен, фруктов, или числовые записи, возникает необходимость посчитать не общее количество записей, а только количество уникальных записей.

Если необходимо подсчитать общее количество числовых данных, то используется функция СЧЁТ (COUNT), а если необходимо посчитать не числовые данные, тогда – СЧЁТЗ (COUNTA).

Для подсчета уникальных записей используется следующая конструкция из формул СУММ (SUM) и СЧЁТЕСЛИ (COUNTIF):

=СУММ(1/СЧЁТЕСЛИ(A2:A11;A2:A11))

это формула массива, т.е. после ее введения необходимо нажимать не просто "Enter", а сочетание "Ctrl+Shift+Enter".

Если в перечне нет пустых ячеек конструкция отлично работает, но, если попадется пустая ячейка, формула выдаст ошибку. Чтобы иметь возможность считать уникальные записи в массивах с пустыми ячейками, необходима небольшая модернизация формулы добавлением функции ЕСЛИОШИБКА (IFERROR):

=СУММ(ЕСЛИОШИБКА(1/СЧЁТЕСЛИ(A2:A13;A2:A13);0))