СУММЕСЛИМН (SUMIFS)

Функция СУММЕСЛИМН (SUMIFS)

Суммирует ячейки в диапазоне, удовлетворяющие нескольким условиям. Например, если необходимо суммировать числа в диапазоне A1:A20, которым соответствуют значения в диапазоне B1:B20 больше нуля (0) и значения в диапазоне C1:C20 меньше 10, можно использовать следующую формулу:

=СУММЕСЛИМН(A1:A20, B1:B20, ">0", C1:C20, "<10")

​Важно! Порядок аргументов в функциях СУММЕСЛИМН и СУММЕСЛИ различается. В СУММЕСЛИМН аргумент диапазон_суммирования является первым аргументом, а в СУММЕСЛИ — третьим. При копировании и изменении этих похожих функций необходимо следить за тем, чтобы аргументы были указаны в правильном порядке.

Синтаксис

СУММЕСЛИМН(диапазон_суммирования; диапазон_условий1; условия1; 
[диапазон_условий2; условия2]; ...)

Аргументы:

  • Диапазон_суммирования.    Обязательный аргумент. Одна или несколько ячеек для суммирования, включая числа или имена, диапазоны или ссылки на ячейки. Пустые ячейки и ячейки, содержащие текстовые значения, пропускаются.
  • Диапазон_условий1.    Обязательный аргумент. Первый диапазон, в котором проверяется соответствующее условие.
  • Условия1.    Обязательный аргумент. Условия в виде числа, выражения, ссылки на ячейку или в виде текста, определяющие, какие ячейки в аргументе диапазон_критериев1 будут просуммированы. Например, условия могут быть представлены в следующем виде: 32, ">32", B4, "яблоки" или "32".
  • Диапазон_условий2, условия2, …    Необязательный аргумент. Дополнительные диапазоны и условия для них. Разрешается использовать до 127 пар диапазонов и условий.

​Замечания

  • Каждая ячейка в аргументе диапазон_суммирования суммируется только в том случае, если выполнены все указанные условия, соответствующие этой ячейке. Например, формула содержит два аргумента диапазон_условий. Если первая ячейка аргумента диапазон_условий1 соответствует аргументу условия1, а первая ячейка аргумента диапазон_условий2 — аргументу условия2, первая ячейка аргумента диапазон_суммирования добавляется к сумме (и т. д. для всех остальных ячеек в указанных диапазонах).
  • Ячейки в аргументе диапазон_суммирования, которым присвоено значение ИСТИНА, оцениваются как 1; ячейки в аргументе диапазон_суммирования, которым присвоено значение ЛОЖЬ, оцениваются как 0 (нуль).
  • В отличие от аргументов диапазона и условий в функции СУММЕСЛИ, в функции СУММЕСЛИМН каждый аргумент диапазон_условий обязательно должен иметь то же количество строк и столбцов, что и аргумент диапазон_суммирования.
  • В условии можно использовать подстановочные знаки: вопросительный знак (?) и звездочку (*) . Вопросительный знак соответствует одному любому символу, а звездочка — любой последовательности знаков. Если требуется найти непосредственно вопросительный знак (или звездочку), необходимо поставить перед ним знак "тильда" (~).

Пример:


Scroll Up