СУММЕСЛИ (SUMIF)

Функция СУММЕСЛИ (SUMIF)

Функция СУММЕСЛИ используется, если необходимо просуммировать значения диапазона, соответствующие указанному критерию.

Синтаксис

СУММЕСЛИ(диапазон, условие, [диапазон_суммирования])

Предположим, например, что в столбце с числами необходимо просуммировать только значения, превышающие 5. Для этого можно использовать указанную ниже формулу.

=СУММЕСЛИ(B2:B25,">5")

В данном примере на соответствие критерию проверяются суммируемые значения. При необходимости условие можно применить к одному диапазону, а просуммировать соответствующие значения из другого диапазона. Например, формула =СУММЕСЛИ(B2:B5; "Иван"; C2:C5) суммирует только те значения из диапазона C2:C5, для которых соответствующие значения из диапазона B2:B5 равны "Иван".

Аргументы:

  • Диапазон.    Обязательный аргумент. Диапазон ячеек, оцениваемых по критериям. Ячейки в каждом диапазоне должны содержать числа, имена, массивы или ссылки на числа. Пустые ячейки и ячейки, содержащие текстовые значения, пропускаются.
  • Условие.    Обязательный аргумент. Условие в форме числа, выражения, ссылки на ячейку, текста или функции, определяющее, какие ячейки необходимо просуммировать. Например, условие может быть представлено в следующем виде: 32, ">32", B5, "32", "яблоки" или СЕГОДНЯ().

Важно! Все текстовые условия и условия с логическими и математическими знаками необходимо заключать в двойные кавычки ("). Если условием является число, использовать кавычки не требуется.

  • ​Диапазон_суммирования.    Необязательный аргумент. Ячейки, значения из которых суммируются, если они отличаются от ячеек, указанных в качестве диапазона. Если аргумент диапазон_суммирования опущен, Microsoft Excel суммирует ячейки, указанные в аргументе диапазон (те же ячейки, к которым применяется условие).

Примечание:

  • В аргументе условие можно использовать подстановочные знаки: вопросительный знак (?) и звездочку (*). Вопросительный знак соответствует одному любому символу, а звездочка — любой последовательности символов. Если требуется найти непосредственно вопросительный знак (или звездочку), необходимо поставить перед ним знак "тильда" (~).

Замечания

  • Функция СУММЕСЛИ возвращает неправильные результаты, если она используется для сопоставления строк длиннее 255 символов со строкой #ЗНАЧ!.
  • Аргумент диапазон_суммирования может не совпадать по размерам с аргументом диапазон. При определении фактических ячеек, подлежащих суммированию, в качестве начальной используется верхняя левая ячейка аргумента диапазон_суммирования, а затем суммируются ячейки части диапазона, соответствующей по размерам аргументу диапазон.

Пример:


Scroll Up