ТИП.ОШИБКИ (ERROR.TYPE)

Функция ТИП.ОШИБКИ (ERROR.TYPE)

Возвращает номер, соответствующий одному из возможных значений ошибок в Microsoft Excel, или значение ошибки #Н/Д, если ошибка отсутствует. Функцию ТИП.ОШИБКИ можно использовать в функции ЕСЛИ для проверки значения ошибки и возврата строки текста вместо соответствующего значения ошибки.

Синтаксис

ТИП.ОШИБКИ(значение_ошибки)

Аргументы:

  • Значение_ошибки    — обязательный аргумент. Значение ошибки, для которого определяется номер. Хотя аргумент "значение_ошибки" может быть фактическим значением ошибки, обычно он представляет ссылку на ячейку, содержащую формулу, значение которой требуется проверить.
Значение_ошибки Возвращаемый ТИП.ОШИБКИ
#ПУСТО! 1
#ДЕЛ/0! 2
#ЗНАЧ! 3
#ССЫЛ! 4
#ИМЯ? 5
#ЧИСЛО! 6
#Н/Д 7
#ОЖИДАНИЕ_ДАННЫХ 8
Любое другое #Н/Д

Пример:

Скопируйте даные из таблицы, начиная с первой ячейки, а затем ведите формулы из второй таблицы.

Даные
#ПУСТО!
#ДЕЛ/0!
Формула Описание Результат
=ТИП.ОШИБКИ(A2) Номер ошибки #ПУСТО! (1). 1
=ЕСЛИ(ТИП.ОШИБКИ(A3)<3;ВЫБОР(ТИП.ОШИБКИ(A3);"Диапазоны не пересекаются";"Делитель — 0 (нуль)")) Проверяет ячейку A3 на наличие ошибки #ПУСТО! или #ДЕЛ/0!. Если ячейка содержит такую ошибку, номер значения ошибки используется в функции ВЫБОР для отображения одного из двух сообщений. В противном случае возвращается значение ошибки #Н/Д. Делитель — 0

 


Scroll Up