Функции Е (IS)

Функции Е (IS)

Каждая из функций Е проверяет указанное значение и возвращает в зависимости от результата значение ИСТИНА или ЛОЖЬ. Например, функция ЕПУСТО возвращает логическое значение ИСТИНА, если проверяемое значение является ссылкой на пустую ячейку; в противном случае возвращается логическое значение ЛОЖЬ. Функции Е используются для получения сведений о значении перед выполнением с ним вычисления или другого действия. Например, для выполнения другого действия при возникновении ошибки можно использовать функцию ЕОШИБКА в сочетании с функцией ЕСЛИ:

=ЕСЛИ(ЕОШИБКА(A1); "Произошла ошибка."; A1 * 2)

Эта формула проверяет наличие ошибки в ячейке A1. При возникновении ошибки функция ЕСЛИ возвращает сообщение "Произошла ошибка." Если ошибки отсутствуют, функция ЕСЛИ вычисляет произведение A1*2.

Синтаксис

ЕПУСТО(значение)
ЕОШ(значение)
ЕОШИБКА(значение)
ЕЛОГИЧ(значение)
ЕНД(значение) 
ЕНЕТЕКСТ(значение) 
ЕЧИСЛО(значение) 
ЕССЫЛКА(значение) 
ЕТЕКСТ(значение)

Аргументы функции Е:

  • Значение.    Обязательный аргумент. Значением этого аргумента может быть пустая ячейка, значение ошибки, логическое значение, текст, число, ссылка на любой из перечисленных объектов или имя такого объекта.
Функция Возвращает значение ИСТИНА, если
ЕПУСТО Аргумент "значение" ссылается на пустую ячейку
ЕОШ Аргумент "значение" ссылается на любое значение ошибки, кроме #Н/Д
ЕОШИБКА  Аргумент "значение" ссылается на любое значение ошибки (#Н/Д, #ЗНАЧ!, #ССЫЛ!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО!)
ЕЛОГИЧ Аргумент "значение" ссылается на логическое значение
ЕНД Аргумент "значение" ссылается на значение ошибки #Н/Д (значение недоступно)
ЕНЕТЕКСТ Аргумент "значение" ссылается на любой элемент, который не является текстом. (Обратите внимание, что функция возвращает значение ИСТИНА, если аргумент ссылается на пустую ячейку.)
ЕЧИСЛО Аргумент "значение" ссылается на число
ЕССЫЛКА Аргумент "значение" ссылается на ссылку
ЕТЕКСТ Аргумент "значение" ссылается на текст

Замечания:

  • Аргументы в функциях Е не преобразуются. Любые числа, заключенные в кавычки, воспринимаются как текст. Например, в большинстве других функций, требующих числового аргумента, текстовое значение "19" преобразуется в число 19. Однако в формуле ЕЧИСЛО("19") это значение не преобразуется из текста в число, и функция ЕЧИСЛО возвращает значение ЛОЖЬ.
  • С помощью этих функций удобно проверять результаты вычислений в формулах. Комбинируя эти функции с функцией ЕСЛИ, можно находить ошибки в формулах (см. приведенные ниже примеры).

Пример:


Scroll Up